mirror of
https://git.openwrt.org/feed/video.git
synced 2025-05-08 03:15:59 +08:00
wpewebkit: update to version 2.46.7
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
1234953638
commit
462c951053
@ -1,12 +1,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wpewebkit
|
||||
PKG_VERSION:=2.46.5
|
||||
PKG_VERSION:=2.46.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://wpewebkit.org/releases
|
||||
PKG_HASH:=2efd4831efcf86e29546c028d6f17a7b775b61b6499ed62399a00da8f06ea456
|
||||
PKG_HASH:=cf3e47638595d86de96abdb94db69a836c8aa509fc063be714f52c5a24bb5cd5
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later BSD-2-Clause
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- a/Source/WTF/wtf/Platform.h
|
||||
+++ b/Source/WTF/wtf/Platform.h
|
||||
@@ -114,7 +114,6 @@
|
||||
/* FIXME: This does not belong in Platform.h and should instead be included in another mechanism (compiler option, prefix header, config.h, etc) */
|
||||
/* ICU configuration. Some of these match ICU defaults on some platforms, but we would like them consistently set everywhere we build WebKit. */
|
||||
#define U_HIDE_DEPRECATED_API 1
|
||||
-#define U_SHOW_CPLUSPLUS_API 0
|
||||
#ifdef __cplusplus
|
||||
#define UCHAR_TYPE char16_t
|
||||
#endif
|
@ -1,6 +1,6 @@
|
||||
--- a/Source/WebCore/platform/graphics/gstreamer/mse/MediaSourcePrivateGStreamer.cpp
|
||||
+++ b/Source/WebCore/platform/graphics/gstreamer/mse/MediaSourcePrivateGStreamer.cpp
|
||||
@@ -170,6 +170,7 @@ void MediaSourcePrivateGStreamer::startP
|
||||
@@ -184,6 +184,7 @@ void MediaSourcePrivateGStreamer::startP
|
||||
m_playerPrivate.startSource(tracks);
|
||||
}
|
||||
|
||||
@ -8,7 +8,7 @@
|
||||
TrackID MediaSourcePrivateGStreamer::registerTrackId(TrackID preferredId)
|
||||
{
|
||||
ASSERT(isMainThread());
|
||||
@@ -203,6 +204,7 @@ bool MediaSourcePrivateGStreamer::unregi
|
||||
@@ -218,6 +219,7 @@ bool MediaSourcePrivateGStreamer::unregi
|
||||
|
||||
return res;
|
||||
}
|
||||
|
Loading…
x
Reference in New Issue
Block a user