mirror of
https://git.yoctoproject.org/poky-contrib
synced 2025-05-08 15:42:17 +08:00

Move classes to classes-global or classes-recipe as appropriate to take advantage of new bitbake functionality to check class scope/usage. (From OE-Core rev: f5c128008365e141082c129417eb72d2751e8045) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
41 lines
1.6 KiB
Plaintext
41 lines
1.6 KiB
Plaintext
#
|
|
# Copyright OpenEmbedded Contributors
|
|
#
|
|
# SPDX-License-Identifier: MIT
|
|
#
|
|
|
|
python read_subpackage_metadata () {
|
|
import oe.packagedata
|
|
|
|
vars = {
|
|
"PN" : d.getVar('PN'),
|
|
"PE" : d.getVar('PE'),
|
|
"PV" : d.getVar('PV'),
|
|
"PR" : d.getVar('PR'),
|
|
}
|
|
|
|
data = oe.packagedata.read_pkgdata(vars["PN"], d)
|
|
|
|
for key in data.keys():
|
|
d.setVar(key, data[key])
|
|
|
|
for pkg in d.getVar('PACKAGES').split():
|
|
sdata = oe.packagedata.read_subpkgdata(pkg, d)
|
|
for key in sdata.keys():
|
|
if key in vars:
|
|
if sdata[key] != vars[key]:
|
|
if key == "PN":
|
|
bb.fatal("Recipe %s is trying to create package %s which was already written by recipe %s. This will cause corruption, please resolve this and only provide the package from one recipe or the other or only build one of the recipes." % (vars[key], pkg, sdata[key]))
|
|
bb.fatal("Recipe %s is trying to change %s from '%s' to '%s'. This will cause do_package_write_* failures since the incorrect data will be used and they will be unable to find the right workdir." % (vars["PN"], key, vars[key], sdata[key]))
|
|
continue
|
|
#
|
|
# If we set unsuffixed variables here there is a chance they could clobber override versions
|
|
# of that variable, e.g. DESCRIPTION could clobber DESCRIPTION:<pkgname>
|
|
# We therefore don't clobber for the unsuffixed variable versions
|
|
#
|
|
if key.endswith(":" + pkg):
|
|
d.setVar(key, sdata[key])
|
|
else:
|
|
d.setVar(key, sdata[key], parsing=True)
|
|
}
|