mirror of
https://git.yoctoproject.org/poky-contrib
synced 2025-05-08 23:52:25 +08:00

as this is correctly set by setuptools3-base already (From OE-Core rev: 6c4705d1cc5812ef6d1b17f46899007f1709af17) Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
15 lines
319 B
Plaintext
15 lines
319 B
Plaintext
#
|
|
# Copyright OpenEmbedded Contributors
|
|
#
|
|
# SPDX-License-Identifier: MIT
|
|
#
|
|
|
|
inherit python_pep517 python3native python3-dir setuptools3-base
|
|
|
|
DEPENDS += "python3-flit-core-native"
|
|
|
|
python_flit_core_do_manual_build () {
|
|
cd ${PEP517_SOURCE_PATH}
|
|
nativepython3 -m flit_core.wheel --outdir ${PEP517_WHEEL_PATH} .
|
|
}
|